Hướng dẫn vá lỗ hổng bảo mật Spectre trên các thiết bị sử dụng phiên bản iOS 9 đến 10.3

  1. Hải Hài Hước

    Hải Hài Hước "Học sinh cá biệt"

    Tham gia ngày:
    23/4/16
    Bài viết:
    4,167
    Đã được thích:
    2,576
    [​IMG]

    Sau khi xác nhận lỗ hổng bảo mật Spectre, Apple đã nhanh chóng phát hành iOS 11.2.2 đi kèm bản vá cho người dùng vào ngày 9/1 vừa qua. Tuy nhiên, đối với các thiết bị đời cũ hoặc những ai vẫn muốn sử dụng phiên bản iOS thấp hơn, chúng ta vẫn có một cách khác để khắc phục vấn đề này mà không cần cập nhật lên iOS 11.2.2. Sau đây là hướng dẫn chi tiết, mời các bạn cùng tham khảo.

    Spectre và SpectrePatch là gì?

    Spectre là một lỗ hổng bảo mật nghiêm trọng xuất hiện trên tất cả các dòng chipset phổ biến như Intel, AMD và ARM cũng bị ảnh hưởng. SpectrePatch chính là một bản vá lỗ hổng Spectre nhằm chống lại các cuộc tấn công và tránh bị tin tặc lợi dụng cơ chế hoạt động của vi xử lí để truy cập vào các thông tin nhạy cảm trên thiết bị iOS, được phát triển bởi lập trình viên @Ryley Angus.

    Về cơ bản, SpectrePatch sử dụng nhiều phương pháp khắc phục lỗ hổng Spectre từ Firefox sau đợt tấn công gần đây, tập chung làm giảm hiệu suất của Webkit.now () và vô hiệu hóa SharedArrayBuffer. Lưu ý, bản patch này chỉ ngăn chặn việc khai thác javascript trên trình duyệt Safari, Chrome hoặc Firefox!

    Cách cài đặt SpectrePatch dành cho phiên bản iOS 9 - 10.3

    B1: Cách vá lỗ hổng Spectre dành cho thiết bị sử dụng iOS 9 và 10.3 yêu cầu người dùng phải jailbreak máy. Trong trường hợp bạn chưa thực hiện thao tác này thì có thể tham khảo qua bài viết dưới đây
    B2: Sau khi jailbreak máy, bạn mở Cydia và thêm nguồn

    Mã:
    https://ryleyangus.com/repo/
    [​IMG]

    B3: Tìm và cài đặt gói Debian SpectrePatch từ repo ryleyangus

    [​IMG]

    B4: Khi quá trình cài đặt kết thúc, bạn phải xác định xem bản vá có hoạt động hay không bằng cách truy cập địa chỉ Ryleyangus Spectretest và lưu ý chỉ số được hiển thị trên màn hình.
    • Nếu số là một số nguyên (dạng 0,1,2, 3 v.v...) thì tức là miếng vá đang hoạt động tốt.
    • Nếu số là một bội số của 0.005 thì miếng vá không hoạt động, đồng nghĩa với việc bạn nên nâng cấp lên phiên bản iOS mới nhất hiện tại.
    [​IMG]


    Xem thêm:
     
    Stevenkillah thích bài này.
  2. tan512

    tan512 "Có làm bài tập"

    Tham gia ngày:
    21/12/15
    Bài viết:
    39
    Đã được thích:
    13
  3. nefertem

    nefertem "Học sinh kém"

    Tham gia ngày:
    11/12/17
    Bài viết:
    138
    Đã được thích:
    45
    số 4
     
  4. Stevenkillah

    Stevenkillah "Có làm bài tập"

    Tham gia ngày:
    11/1/18
    Bài viết:
    25
    Đã được thích:
    5
    Số 1 :rofl: thanks bài viết rất hữu ích
     
  5. dxchien

    dxchien "Mới vô lớp"

    Tham gia ngày:
    21/3/17
    Bài viết:
    2
    Đã được thích:
    0
    Đang 10.2, không cập nhật vì hiệu năng máy giảm đáng kể :big_smile:
     
  6. ceo169

    ceo169 "Có làm bài tập"

    Tham gia ngày:
    28/12/17
    Bài viết:
    26
    Đã được thích:
    6
    bạn ơi nếu dùng điện thoại này mà mình update lên bản mới thì liệu có vá được lỗi không bạn?